I have several debian machines that want to be upgraded from etch to lenny. After changing /etc/apt/sources.list to the new stable version and running apt-get update I got this message:

apt-get update

Get:1 http://security.debian.org stable/updates Release.gpg [189B]
Get:2 http://ftp.de.debian.org lenny Release.gpg [386B]
Hit http://security.debian.org stable/updates Release
Hit http://ftp.de.debian.org lenny Release
Ign http://security.debian.org stable/updates/main Packages/DiffIndex
Ign http://security.debian.org stable/updates/contrib Packages/DiffIndex
Ign http://ftp.de.debian.org lenny/main Packages/DiffIndex
Ign http://security.debian.org stable/updates/non-free Packages/DiffIndex
Ign http://security.debian.org stable/updates/main Sources/DiffIndex
Ign http://security.debian.org stable/updates/contrib Sources/DiffIndex
Ign http://security.debian.org stable/updates/non-free Sources/DiffIndex
Hit http://security.debian.org stable/updates/main Packages
Ign http://ftp.de.debian.org lenny/contrib Packages/DiffIndex
Ign http://ftp.de.debian.org lenny/non-free Packages/DiffIndex
Ign http://ftp.de.debian.org lenny/main Sources/DiffIndex
Ign http://ftp.de.debian.org lenny/contrib Sources/DiffIndex
Ign http://ftp.de.debian.org lenny/non-free Sources/DiffIndex
Hit http://security.debian.org stable/updates/contrib Packages
Hit http://security.debian.org stable/updates/non-free Packages
Hit http://security.debian.org stable/updates/main Sources
Hit http://security.debian.org stable/updates/contrib Sources
Hit http://ftp.de.debian.org lenny/main Packages
Hit http://security.debian.org stable/updates/non-free Sources
Hit http://ftp.de.debian.org lenny/contrib Packages
Hit http://ftp.de.debian.org lenny/non-free Packages
Hit http://ftp.de.debian.org lenny/main Sources
Hit http://ftp.de.debian.org lenny/contrib Sources
Hit http://ftp.de.debian.org lenny/non-free Sources
Fetched 2B in 0s (13B/s)
Reading package lists... Done
W: There is no public key available for the following key IDs:
4D270D06F42584E6
W: You may want to run apt-get update to correct these problems

To fix this problem you need to

apt-get install debian-keyring debian-archive-keyring

apt-key update

apt-get update

and the message will disappear.