Lenny ships with rrdtools version 1.3 which is not supported by nfsen-1.3 (the latest stable version of nfsen). One needs to patch the source code in order to install nfsen

--- libexec/NfSenRRD.pm.old 2009-04-01 10:21:54.000000000 +0200  
+++ libexec/NfSenRRD.pm 2009-04-01 10:11:18.000000000 +0200  
@@ -73,7 +73,7 @@  
  if ( $rrd_version < 1.1 ) { # it's RRD 1.0.x  
   $RRDoffset = 77;  
  }  
- if ( $rrd_version >= 1.2 && $rrd_version < 1.3 ) {  
+ if ( $rrd_version >= 1.2 && $rrd_version < 1.4 ) {  
   $RRDoffset = 67;  
  }